summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-03-21 23:29:10 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-21 23:29:10 +0100
commit03fb5ff6ae01a680c786d9ee148839543c519411 (patch)
treeb903e0c8e3e5dea5b4ef3dcfd063d03e0be5c0ae /gnu/packages/version-control.scm
parent93f178b5a84a8cc5a0c552290191efd2310588b5 (diff)
downloadpatches-03fb5ff6ae01a680c786d9ee148839543c519411.tar
patches-03fb5ff6ae01a680c786d9ee148839543c519411.tar.gz
gnu: libgit2: Avoid Python.
* gnu/packages/patches/libgit2-avoid-python.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/version-control.scm (libgit2)[source]: Use it. [inputs]: Remove python. [native-inputs]: Add guile-2.2.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 385ebeadc9..9a6f96ce14 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
@@ -535,7 +536,8 @@ everything from small to very large projects with speed and efficiency.")
(sha256
(base32
"0swk2dyq5a4p1jn5wvbcsrxckhh808vifxz5y8w663avg541188c"))
- (patches (search-patches "libgit2-mtime-0.patch"))
+ (patches (search-patches "libgit2-avoid-python.patch"
+ "libgit2-mtime-0.patch"))
;; Remove bundled software.
(snippet '(begin
@@ -561,10 +563,10 @@ everything from small to very large projects with speed and efficiency.")
(lambda _ (invoke "./libgit2_clar" "-v" "-Q"))))))
(inputs
`(("libssh2" ,libssh2)
- ("http-parser" ,http-parser)
- ("python" ,python-wrapper)))
+ ("http-parser" ,http-parser)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("guile" ,guile-2.2)
+ ("pkg-config" ,pkg-config)))
(propagated-inputs
;; These two libraries are in 'Requires.private' in libgit2.pc.
`(("openssl" ,openssl)