summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-17 16:50:44 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-18 18:22:06 +0200
commit0fff1495bc83f872c13bc9d407b87801c6dcce99 (patch)
tree83f9d17221accfc680e0d56ae7f947c4f19d9afa /gnu/packages/version-control.scm
parente1287aed0c2bbe63bd56cf43b846be439d16a823 (diff)
downloadpatches-0fff1495bc83f872c13bc9d407b87801c6dcce99.tar
patches-0fff1495bc83f872c13bc9d407b87801c6dcce99.tar.gz
gnu: git: Prevent creating 'perllocal.pod'.
* gnu/packages/version-control.scm (git)[arguments]<#:phases>: Rename 'patch-makefile-shebangs' to 'patch-makefiles'. Add substitution.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 953440a6fd..a412ef8d01 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -186,12 +186,16 @@ as well as the classic centralized workflow.")
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
- (add-after 'configure 'patch-makefile-shebangs
+ (add-after 'configure 'patch-makefiles
(lambda _
(substitute* "Makefile"
(("/bin/sh") (which "sh"))
(("/usr/bin/perl") (which "perl"))
- (("/usr/bin/python") (which "python")))))
+ (("/usr/bin/python") (which "python")))
+ (substitute* "perl/Makefile"
+ ;; Don't create timestamped 'perllocal.pod'.
+ (("\\$< PREFIX=") "$< NO_PERLLOCAL=1 PREFIX="))
+ #t))
(add-after 'configure 'add-PM.stamp
(lambda _
;; Add the "PM.stamp" to avoid "no rule to make target".