summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-29 22:49:00 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-30 11:08:39 +0100
commitadb6462c4ce51fcdc94d3608ad6efb4adf716018 (patch)
treec5306452e40c282bb5c27909dbc6b5a515d54ffc /gnu/packages/version-control.scm
parentd2be7e3c4ba8d6d0dde9b4c0bff623ab85637424 (diff)
downloadpatches-adb6462c4ce51fcdc94d3608ad6efb4adf716018.tar
patches-adb6462c4ce51fcdc94d3608ad6efb4adf716018.tar.gz
packages: Define 'this-package' and 'this-origin'.
* guix/packages.scm (<origin>): Choose 'this-origin' as the 'this' identifier. (<package>): Choose 'this-package'. * gnu/packages/gnucash.scm (gnucash)[arguments]: Use 'this-package' instead of 'this-record'. * gnu/packages/version-control.scm (git)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index fe9b64ba5c..667b2881b1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -51,7 +51,6 @@
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
- #:use-module ((guix records) #:select (this-record))
#:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages documentation)
@@ -409,7 +408,7 @@ as well as the classic centralized workflow.")
,@(transitive-input-references
'inputs
(map (lambda (l)
- (assoc l (package-inputs this-record)))
+ (assoc l (package-inputs this-package)))
'("perl-authen-sasl"
"perl-net-smtp-ssl"
"perl-io-socket-ssl")))))))
@@ -422,7 +421,7 @@ as well as the classic centralized workflow.")
,@(transitive-input-references
'inputs
(map (lambda (l)
- (assoc l (package-inputs this-record)))
+ (assoc l (package-inputs this-package)))
'("perl-cgi")))))))
;; Tell 'git-submodule' where Perl is.