summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-06 23:12:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-04-05 15:02:30 +0300
commitf71d1a08a1eade5dcc1df79d1b66a9524b113253 (patch)
tree18e30056680b24082fa9b559dcf5cb200efb0bac /gnu/packages/version-control.scm
parentf9ab1da0fa1a4cdb100209c2607c7afbbacfb7c6 (diff)
downloadpatches-f71d1a08a1eade5dcc1df79d1b66a9524b113253.tar
patches-f71d1a08a1eade5dcc1df79d1b66a9524b113253.tar.gz
gnu: git-annex-remote-hubic: Change to python2.
* gnu/packages/version-control.scm (git-annex-remote-hubic) [arguments]: Build with python2.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5bcf02090a..70f017956a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1109,15 +1109,16 @@ Mercurial, Bazaar, Darcs, CVS, Fossil, and Veracity.")
(base32
"196g3jkaybjx11nbr51n0cjps3wjzb145ab76y717diqvvxp5v4r"))))
(build-system python-build-system)
+ (arguments `(#:python ,python-2))
(native-inputs
- `(("python-setuptools" ,python-setuptools)
+ `(("python2-setuptools" ,python2-setuptools)
;; for the tests
- ("python-six" ,python-six)))
+ ("python2-six" ,python2-six)))
(propagated-inputs
- `(("python-dateutil" ,python-dateutil-2)
- ("python-futures" ,python-futures)
- ("python-rauth" ,python-rauth)
- ("python-swiftclient" ,python-swiftclient)))
+ `(("python2-dateutil" ,python2-dateutil-2)
+ ("python2-futures" ,python2-futures)
+ ("python2-rauth" ,python2-rauth)
+ ("python2-swiftclient" ,python2-swiftclient)))
(home-page "https://github.com/Schnouki/git-annex-remote-hubic/")
(synopsis "Use hubic as a git-annex remote")
(description