summaryrefslogtreecommitdiff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
commitf056553c6b8ffa36f4ce9fb1c3602a8f4b1de242 (patch)
tree80c815216a3717cf00b615c9cb8840c113eaf79f /gnu/packages/upnp.scm
parent2c9d34166983565120f831284df57a07e2edd2f9 (diff)
parent528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (diff)
downloadpatches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar
patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm45
1 files changed, 1 insertions, 44 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 1c2479064a..390a3387ab 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -47,7 +47,7 @@
(origin
(method url-fetch)
(uri (string-append "https://miniupnp.tuxfamily.org/files/"
- name "-" version ".tar.gz"))
+ "miniupnpc-" version ".tar.gz"))
(sha256
(base32 "0rg1i51lnyq8zgflhcg981kq4348vgq03ndmbgiv7knd1vmfzb8z"))))
(build-system gnu-build-system)
@@ -89,49 +89,6 @@ over IRC, instant messaging, network games, and most server software.")
(license
(x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))
-(define-public monero-miniupnpc
- ;; This package is the bundled version of miniupnpc used with monero.
- ;; Monero-project has been maintaining its own version of the package since
- ;; release 0.12.2.0. It includes security fixes not included in upstream
- ;; releases.
- (let ((revision "0")
- (commit "6a63f9954959119568fbc4af57d7b491b9428d87"))
- (package
- (inherit miniupnpc)
- (name "miniupnpc-monero")
- (version (string-append "2.1-monero-0.12.3.0-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/monero-project/miniupnp/")
- (commit commit)))
- (sha256
- (base32
- "0s67zcz978iapjlq30yy9dl8qda9xhrl3jdi5f99cnbglh5gy16a"))
- (file-name (string-append name "-" version "-checkout"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete miniupnp subprojects except for miniupnpc.
- (for-each
- delete-file-recursively
- '("minissdpd" "miniupnpc-async" "miniupnpc-libevent"
- "miniupnpd" ))
- #t))))
- (arguments
- (substitute-keyword-arguments (package-arguments miniupnpc)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'build 'change-directory
- (lambda _
- (chdir "miniupnpc")
- #t))
- (add-after 'change-directory 'chmod-header-file
- (lambda _
- (chmod "miniupnpc.h" #o644)
- #t)))))))))
-
(define-public libupnp
(package
(name "libupnp")