aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/toys.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
downloadpatches-839167ff9d74fc490b32f6a197591964f73b65e5.tar
patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 05e1dab983..87706d2277 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,7 +19,7 @@
(define-module (gnu packages toys)
#:use-module (gnu packages ncurses)
#:use-module (guix build-system gnu)
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages))
@@ -29,12 +29,13 @@
(version "5.02")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/mtoyoda/" name
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mtoyoda/sl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0fjnnnxxq7zh9bm3yzbj84fgap0rhblxi2m10br83747gxsrcn8y"))))
+ (base32 "1zrfd71zx2px2xpapg45s8xvi81xii63yl0h60q72j71zh4sif8b"))))
(build-system gnu-build-system)
(inputs
`(("ncurses" ,ncurses)))