summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-10 18:38:04 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-11 00:37:50 +0100
commitba583bd2ce887cdd8b99ea55c15b57c5209e4b58 (patch)
tree8fb9c09eda0cb5acbe080ee55b766b716a15c149 /gnu/packages/tor.scm
parent68d85de16383d054dbf4fb5da2437f9cc743e5d2 (diff)
downloadpatches-ba583bd2ce887cdd8b99ea55c15b57c5209e4b58.tar
patches-ba583bd2ce887cdd8b99ea55c15b57c5209e4b58.tar.gz
gnu: torsocks: Upgrade to 2.0.0.
* gnu/packages/tor.scm (torsocks): Update to 2.0.0. [source]: Fetch from git.torproject.org. Use 'torsocks-dns-test.patch'. [arguments, native-inputs]: New fields. [license]: Change to GPL2. * gnu/packages/patches/torsocks-dns-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm37
1 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 3cf45a400e..3b057d422e 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -18,13 +18,16 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages tor)
- #:use-module ((guix licenses) #:select (bsd-3 gpl2+))
+ #:use-module ((guix licenses) #:select (bsd-3 gpl2+ gpl2))
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages libevent)
#:use-module (gnu packages compression)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages tls)
@@ -66,22 +69,36 @@ applications based on the TCP protocol.")
(define-public torsocks
(package
(name "torsocks")
- (version "1.2")
+ (version "2.0.0")
(source (origin
- (method url-fetch)
- (uri (string-append "http://torsocks.googlecode.com/files/torsocks-"
- version ".tar.gz"))
- (sha256
- (base32
- "1m0is5q24sf7jjlkl0icfkdc0m53nbkg0q72s57p48yp4hv7v9dy"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.torproject.org/torsocks.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0an2q5ail9z414riyjbkjkm29504hy778j914baz2gn5hlv2cfak"))
+ (file-name (string-append name "-" version "-checkout"))
+ (patches (list (search-patch "torsocks-dns-test.patch")))))
(build-system gnu-build-system)
- (home-page "http://code.google.com/p/torsocks/")
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (system* "autoreconf" "-vfi"))))))
+ (native-inputs `(("autoconf" ,(autoconf-wrapper))
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("perl-test-harness" ,perl-test-harness)))
+ (home-page "http://www.torproject.org/")
(synopsis "Use socks-friendly applications with Tor")
(description
"Torsocks allows you to use most socks-friendly applications in a safe
way with Tor. It ensures that DNS requests are handled safely and explicitly
rejects UDP traffic from the application you're using.")
- (license gpl2+)))
+
+ ;; All the files explicitly say "version 2 only".
+ (license gpl2)))
(define-public privoxy
(package