summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-18 23:39:03 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-18 23:45:11 +0200
commita2d648992a1d0510bf1dd160c320ec210fd285c2 (patch)
tree97ccb2712347d6e85fe1e595f22bc242e2223ea4 /gnu/packages/tls.scm
parent5315fcfd773405506d38ec26dd85f05113611f70 (diff)
downloadpatches-a2d648992a1d0510bf1dd160c320ec210fd285c2.tar
patches-a2d648992a1d0510bf1dd160c320ec210fd285c2.tar.gz
gnu: libressl: Do not use 'getentropy'.
* gnu/packages/tls.scm (libressl)[arguments]: New field.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 1c99a3ad75..50e9de4806 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -442,6 +442,11 @@ required structures.")
(base32
"0c4awq45cl757fv7f7f75i5i0ibc6v7ns13n7xvfak7chv2lrqql"))))
(build-system gnu-build-system)
+ (arguments
+ ;; Do as if 'getentropy' was missing since older Linux kernels lack it
+ ;; and libc would return ENOSYS, which is not properly handled.
+ ;; See <https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00235.html>.
+ '(#:configure-flags '("ac_cv_func_getentropy=no")))
(native-search-paths
;; FIXME: These two variables must designate a single file or directory
;; and are not actually "search paths." In practice it works OK in