summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-05 18:54:48 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-05 19:03:34 +0200
commite9aa8d0ccb4d91d88a2f1f249e71b7e8aefdb164 (patch)
tree766342e3e2e15b3b27803e1c52c5369eec79ac75 /gnu/packages/tls.scm
parent90e1cdae0c9a17004dd8e118c4cdff489e72ce17 (diff)
downloadpatches-e9aa8d0ccb4d91d88a2f1f249e71b7e8aefdb164.tar
patches-e9aa8d0ccb4d91d88a2f1f249e71b7e8aefdb164.tar.gz
gnu: Fix ambiguity between openssl package and license in tls module.
* gnu/packages/tls.scm: Prefix imported licenses.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 63893c0462..3206aa6c77 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -20,8 +20,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages tls)
- #:use-module ((guix licenses)
- #:select (lgpl2.0+ lgpl2.1+ bsd-3 openssl))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
@@ -63,7 +62,7 @@
for transmitting machine-neutral encodings of data objects in computer
networking, allowing for formal validation of data according to some
specifications.")
- (license lgpl2.0+)))
+ (license license:lgpl2.0+)))
(define-public p11-kit
(package
@@ -101,7 +100,7 @@ provides a standard configuration setup for installing PKCS#11 modules
in such a way that they are discoverable. It also solves problems with
coordinating the use of PKCS#11 by different components or libraries
living in the same process.")
- (license bsd-3)))
+ (license license:bsd-3)))
(define-public gnutls
(package
@@ -174,7 +173,7 @@ living in the same process.")
and DTLS protocols. It is provided in the form of a C library to support the
protocols, as well as to parse and write X.5009, PKCS 12, OpenPGP and other
required structures.")
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public openssl
(package
@@ -228,7 +227,7 @@ required structures.")
(synopsis "SSL/TLS implementation")
(description
"OpenSSL is an implementation of SSL/TLS")
- (license openssl)
+ (license license:openssl)
(home-page "http://www.openssl.org/")))
(define-public perl-net-ssleay