summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-26 21:37:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-26 22:35:34 +0100
commitad8254c23a86c3ca4ca32bc68fc8d76954aa80fd (patch)
treeaff2498c647f5e6f94bd224530ff5eaf3b509300 /gnu/packages/tls.scm
parent3a1c3642d4d611c5516a8ba5b6bc7e39bdc1c9ae (diff)
downloadpatches-ad8254c23a86c3ca4ca32bc68fc8d76954aa80fd.tar
patches-ad8254c23a86c3ca4ca32bc68fc8d76954aa80fd.tar.gz
gnu: OpenSSL: Remove replacement package.
* gnu/packages/tls.scm (openssl): Update to 1.1.1e. [replacement]: Remove. (openssl-1.1.1e): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 45ee67fa9c..f6310222b9 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -280,8 +280,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (version "1.1.1d")
- (replacement openssl-1.1.1e)
+ (version "1.1.1e")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -293,7 +292,7 @@ required structures.")
"/openssl-" version ".tar.gz")))
(sha256
(base32
- "1whinyw402z3b9xlb3qaxv4b9sk4w1bgh9k0y8df1z4x3yy92fhy"))
+ "1gnwlri1dphr5wdzmg9vlhkh6aq2yqgpfkpmffzwjlfb26n62kv9"))
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))))
(build-system gnu-build-system)
(outputs '("out"
@@ -403,24 +402,6 @@ required structures.")
(license license:openssl)
(home-page "https://www.openssl.org/")))
-(define openssl-1.1.1e
- (package
- (inherit openssl)
- (version "1.1.1e")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "https://www.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/"
- "openssl-" version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/openssl-" version ".tar.gz")))
- (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
- (sha256
- (base32
- "1gnwlri1dphr5wdzmg9vlhkh6aq2yqgpfkpmffzwjlfb26n62kv9"))))))
-
(define-public openssl-1.0
(package
(inherit openssl)