summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-10 00:55:42 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-10 00:55:42 +0200
commit7a05fdd0e1d5e5e26e94014d87bf85575bbec780 (patch)
tree6f68b8832b4465c9aeee734997c168840b7b1ee0 /gnu/packages/time.scm
parent36175a3a9eb5bd4096de4e06e1f6b0e8cd895d84 (diff)
parent760d90cc6a5c0f9eb46ad18a30da5520fac2525e (diff)
downloadpatches-7a05fdd0e1d5e5e26e94014d87bf85575bbec780.tar
patches-7a05fdd0e1d5e5e26e94014d87bf85575bbec780.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 9bbfe07803..9aad36e587 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,6 +66,26 @@ program uses. The display output of the program can be customized or saved
to a file.")
(license gpl3+)))
+(define-public python-pytimeparse
+ (package
+ (name "python-pytimeparse")
+ (version "1.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytimeparse" version))
+ (sha256
+ (base32
+ "02kaambsgpjx3zi42j6l11rwms2p35b9hsk4f3kdf979gd3kcqg8"))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (build-system python-build-system)
+ (home-page "https://github.com/wroberts/pytimeparse")
+ (synopsis "Time expression parser")
+ (description "This small Python module parses various kinds of time
+expressions.")
+ (license expat)))
+
(define-public python-pytzdata
(package
(name "python-pytzdata")