summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-17 09:54:11 -0400
committerMark H Weaver <mhw@netris.org>2015-04-17 09:54:11 -0400
commit933204e5b1473a54367aef1f90de22424e9074ab (patch)
treed0ccfee2b903c5fac827bc4a52ec7de17bdc1e7b /gnu/packages/textutils.scm
parent9128e323c0a23243c3f70b1716c68ad0b241f30d (diff)
parent5e25ebe2fa70297d094fe891b81c4970e45a906a (diff)
downloadpatches-933204e5b1473a54367aef1f90de22424e9074ab.tar
patches-933204e5b1473a54367aef1f90de22424e9074ab.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu-system.am gnu/packages/gstreamer.scm
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index c9483697df..08b1b64c57 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -23,6 +23,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages python))
(define-public recode
@@ -124,3 +125,33 @@ libenca and several charset conversion libraries and tools.")
normalization, case-folding, and other operations for data in the UTF-8
encoding, supporting Unicode version 7.0.")
(license license:expat)))
+
+(define-public libgtextutils
+ (package
+ (name "libgtextutils")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/agordon/libgtextutils/releases/download/"
+ version "/libgtextutils-" version ".tar.gz"))
+ (sha256
+ (base32 "0jiybkb2z58wa2msvllnphr4js2hvjvh988pavb3mzkgr6ihwbkr"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (alist-cons-after
+ 'unpack 'autoreconf
+ (lambda _ (zero? (system* "autoreconf" "-vif")))
+ %standard-phases)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/agordon/libgtextutils")
+ (synopsis "Gordon's text utils library")
+ (description
+ "libgtextutils is a text utilities library used by the fastx toolkit from
+the Hannon Lab.")
+ (license license:agpl3+)))