summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2015-12-10 16:15:04 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 16:27:50 +0100
commite522d84035ba22e536b3ed2141f7c2062cfab6eb (patch)
tree2c03da1f80bd7a5c97294869c0449d4c9c53a4b2 /gnu/packages/textutils.scm
parentb01bbbcf3d28db885a48f74908214b12e18e7861 (diff)
downloadpatches-e522d84035ba22e536b3ed2141f7c2062cfab6eb.tar
patches-e522d84035ba22e536b3ed2141f7c2062cfab6eb.tar.gz
gnu: Add libconfig.
* gnu/packages/textutils.scm (libconfig): New variable.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index e0202905d0..537a840247 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -179,3 +180,24 @@ the Hannon Lab.")
"CityHash provides hash functions for strings. The functions mix the
input bits thoroughly but are not suitable for cryptography.")
(license license:expat))))
+
+(define-public libconfig
+ (package
+ (name "libconfig")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.hyperrealm.com/libconfig/"
+ "libconfig-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xh3hzk63v4y8815lc5209m3s6ms2cpgw4h5hg462i4f1lwsl7g3"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.hyperrealm.com/libconfig/")
+ (synopsis "C/C++ configuration file library")
+ (description
+ "Libconfig is a simple library for manipulating structured configuration
+files. This file format is more compact and more readable than XML. And
+unlike XML, it is type-aware, so it is not necessary to do string parsing in
+application code.")
+ (license license:lgpl2.1+)))