aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-06 12:00:29 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-06 12:00:29 +0200
commit933d2fe4cfb380f66af631a2203ec23c367e5b1a (patch)
treef10581ed0da1911eed9b02e69d999ba481d9d3c6 /gnu/packages/textutils.scm
parentf8835ff4b3dd59d59bf44838d05d3d60114d15d2 (diff)
parent998afc3608242b75051f43ece36d52474c51e285 (diff)
downloadpatches-933d2fe4cfb380f66af631a2203ec23c367e5b1a.tar
patches-933d2fe4cfb380f66af631a2203ec23c367e5b1a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 73a0532478..71cf25b224 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -271,3 +272,23 @@ Consequently, the computation has a flat performance characteristic,
correlated with data variation rather than file size. pfff can be as reliable
as existing hashing techniques, with provably negligible risk of collisions.")
(license license:bsd-3)))
+
+(define-public oniguruma
+ (package
+ (name "oniguruma")
+ (version "5.9.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/kkos/"
+ "oniguruma/releases/download/v" version
+ "/onig-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19s79vsclqn170mw0ajwv7j37qsbn4f1yjz3yavnhvva6c820r6m"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/kkos/oniguruma")
+ (synopsis "Regular expression library")
+ (description "Oniguruma is a regular expressions library. The special
+characteristic of this library is that different character encoding for every
+regular expression object can be specified.")
+ (license license:bsd-2)))