summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-21 11:58:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-21 12:04:34 +0200
commit99293380314651858ef2f58bc93429f46b1ce1d8 (patch)
tree487b60960f78b882026244ebbe2091f84d2394d2 /gnu/packages/textutils.scm
parent39ff1d8930df2c53beb174cd9ee2b34a5c7b005d (diff)
downloadpatches-99293380314651858ef2f58bc93429f46b1ce1d8.tar
patches-99293380314651858ef2f58bc93429f46b1ce1d8.tar.gz
gnu: utf8proc: Update to 2.4.0.
* gnu/packages/textutils.scm (utf8proc): Update to 2.4.0. [inputs]: Rename to ... [native-inputs]: ... this. Update Unicode test data and add PERL. [arguments]: End phase on #t.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 0b3ea492fb..d1dc14e6d7 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -140,7 +140,7 @@ libenca and several charset conversion libraries and tools.")
(define-public utf8proc
(package
(name "utf8proc")
- (version "2.1.1")
+ (version "2.4.0")
(source
(origin
(method git-fetch)
@@ -149,23 +149,26 @@ libenca and several charset conversion libraries and tools.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1brr8nnpam7y8l9j8fppdpdqvfyfxliw20z41qfip6ygz9pvcsiq"))))
+ (base32 "1i42hqwc8znqii9brangwkxk5cyc2lk95ip405fg88zr7z2ncr34"))))
(build-system gnu-build-system)
- (inputs ; test data that is otherwise downloaded with curl
+ (native-inputs ;test data that is otherwise downloaded with curl
`(("NormalizationTest.txt"
,(origin
(method url-fetch)
- (uri (string-append "http://www.unicode.org/Public/9.0.0/ucd/"
+ (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
"NormalizationTest.txt"))
(sha256
- (base32 "1fxrz0bilsbwl685336aqi88k62i6nqhm62rvy4zhg3bcm4dhj1d"))))
+ (base32 "0hb97k9xv1lr847hwz0719ksqy39s47xw6k01dgs1368jdibvawc"))))
("GraphemeBreakTest.txt"
,(origin
(method url-fetch)
- (uri (string-append "http://www.unicode.org/Public/9.0.0/ucd/"
+ (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
"auxiliary/GraphemeBreakTest.txt"))
(sha256
- (base32 "0qbhyhmf0778lc2hcwlpizrvmdxwpk959v2q2wb8abv09ba7wvn7"))))))
+ (base32 "0qc90ppmrwfn3y9cdn8jcjrn7qpdf0fhxkwh945yp4rvh37mbgcm"))))
+
+ ;; For tests.
+ ("perl" ,perl)))
(arguments
'(#:make-flags (list "CC=gcc"
(string-append "prefix=" (assoc-ref %outputs "out")))
@@ -180,7 +183,8 @@ libenca and several charset conversion libraries and tools.")
'("NormalizationTest.txt" "GraphemeBreakTest.txt"))
(substitute* "data/GraphemeBreakTest.txt"
(("÷") "/")
- (("×") "+")))))))
+ (("×") "+"))
+ #t)))))
(home-page "https://juliastrings.github.io/utf8proc/")
(synopsis "C library for processing UTF-8 Unicode data")
(description "utf8proc is a small C library that provides Unicode