aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-14 17:21:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-14 17:21:46 +0200
commit61b1df6f2791a2afa291b56708d73a5264ca70eb (patch)
tree314ddb96391b25e83e9a31637be0f1a7f52cc249 /gnu/packages/text-editors.scm
parentbdb8267680f14ee5d3df9d029f23279c1457c211 (diff)
parent4be014128e1c422f37b56f9a6b3420b4e85c4302 (diff)
downloadpatches-61b1df6f2791a2afa291b56708d73a5264ca70eb.tar
patches-61b1df6f2791a2afa291b56708d73a5264ca70eb.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 920868b52d..98df48119a 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
+;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages assembly)
#:use-module (gnu packages boost)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gcc)
@@ -189,3 +191,39 @@ development focuses on keeping weight down to a minimum, only the most essential
features are implemented in the editor. Leafpad is simple to use, is easily
compiled, requires few libraries, and starts up quickly. ")
(license license:gpl2+)))
+
+(define-public e3
+ (package
+ (name "e3")
+ (version "2.82")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://sites.google.com/site/e3editor/Home/"
+ "e3-" version ".tgz"))
+ (sha256
+ (base32
+ "0919kadkas020maqq37852isnzp053q2fnws2zh3mz81d1jiviak"))
+ (modules '((guix build utils)))
+
+ ;; Remove pre-built binaries.
+ (snippet '(delete-file-recursively "bin"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("nasm" ,nasm)))
+ (home-page "https://sites.google.com/site/e3editor/")
+ (synopsis "Tiny text editor written in assembly")
+ (description
+ "e3 is a micro text editor with an executable code size between 3800 and
+35000 bytes. Except for ``syntax highlighting'', the e3 binary supports all
+of the basic functions one expects plus built in arithmetic calculations.
+UTF-8 coding of unicode characters is supported as well. e3 can use
+Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
+16, 32, and 64-bit CPUs.")
+ (supported-systems '("x86_64-linux" "i686-linux"))
+ (license license:gpl2+)))