summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-16 20:37:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-17 04:02:09 +0200
commitfbe8ebec9e886074a3897be76eb1929c856eadd2 (patch)
treea9e9b76ae2f8881d44265c54bc9265ca57cc0191 /gnu/packages/text-editors.scm
parentb30c23c433ca6627484098f03ad91dd8341babb9 (diff)
downloadpatches-fbe8ebec9e886074a3897be76eb1929c856eadd2.tar
patches-fbe8ebec9e886074a3897be76eb1929c856eadd2.tar.gz
gnu: kakoune: Update to 2018.04.13.
* gnu/packages/text-editors.scm (kakoune): Update to 2018.04.13. Remove LET binding for the git revision and re-indent accordingly. [version, source]: Replace the git checkout with new release tarball. [arguments]: Remove ‘fix-test-permissions’ phase. [native-inputs]: Add PKG-CONFIG.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm94
1 files changed, 45 insertions, 49 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 42f65d8e46..6d8d800fd4 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -100,59 +100,55 @@ based command language.")
license:expat)))) ; lexers and libutf.[ch]
(define-public kakoune
- (let ((commit "125c8b7e80995732e0d8c87b82040025748f1b4f")
- (revision "1"))
- (package
- (name "kakoune")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
- (source
- (origin
- (file-name (string-append "kakoune-" version "-checkout"))
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mawww/kakoune.git")
- (commit commit)))
- (sha256
- (base32
- "19qs99l8r9p1vi5pxxx9an22fvi7xx40qw3jh2cnh2mbacawvdyb"))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- ;; kakoune uses confstr with _CS_PATH to find out where to find
- ;; a posix shell, but this doesn't work in the build
- ;; environment. This substitution just replaces that result
- ;; with the "sh" path.
- (substitute* "src/shell_manager.cc"
- (("if \\(m_shell.empty\\(\\)\\)" line)
- (string-append "m_shell = \"" (which "sh")
- "\";\n " line)))
- #t))
- (delete 'configure)
- ;; kakoune requires us to be in the src/ directory to build
- (add-before 'build 'chdir
- (lambda _ (chdir "src") #t))
- (add-before 'check 'fix-test-permissions
- (lambda _
- ;; Out git downloader doesn't give us write permissions, but
- ;; without them the tests fail.
- (zero? (system* "chmod" "-R" "u+w" "../test")))))))
- (native-inputs `(("asciidoc" ,asciidoc)
- ("ruby" ,ruby)))
- (inputs `(("ncurses" ,ncurses)
- ("boost" ,boost)))
- (synopsis "Vim-inspired code editor")
- (description
- "Kakoune is a code editor heavily inspired by Vim, as such most of its
+ (package
+ (name "kakoune")
+ (version "2018.04.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mawww/kakoune/"
+ "releases/download/v" version "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1kkzs5nrjxzd1jq7a4k7qfb5kg05871z0r3d9c0yhz9shf6wz36d"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; kakoune uses confstr with _CS_PATH to find out where to find
+ ;; a posix shell, but this doesn't work in the build
+ ;; environment. This substitution just replaces that result
+ ;; with the "sh" path.
+ (substitute* "src/shell_manager.cc"
+ (("if \\(m_shell.empty\\(\\)\\)" line)
+ (string-append "m_shell = \"" (which "sh")
+ "\";\n " line)))
+ #t))
+ (delete 'configure) ; no configure script
+ ;; kakoune requires us to be in the src/ directory to build
+ (add-before 'build 'chdir
+ (lambda _ (chdir "src") #t)))))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("pkg-config" ,pkg-config)
+ ("ruby" ,ruby)))
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("boost" ,boost)))
+ (synopsis "Vim-inspired code editor")
+ (description
+ "Kakoune is a code editor heavily inspired by Vim, as such most of its
commands are similar to Vi's ones, and it shares Vi's \"keystrokes as a text
editing language\" model. Kakoune has a strong focus on interactivity, most
commands provide immediate and incremental results, while still being
competitive (as in keystroke count) with Vim.")
- (home-page "http://kakoune.org/")
- (license license:unlicense))))
+ (home-page "http://kakoune.org/")
+ (license license:unlicense)))
(define-public joe
(package