summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-14 23:05:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:48 +0200
commit6090b6c47423e54b7929d267f431969c515255e7 (patch)
treee0c5dc83628334d03da219e544f7bf9b5b15b9c4 /gnu/packages/tex.scm
parent1333198da836b5423a903fc618b0c512c859486c (diff)
downloadpatches-6090b6c47423e54b7929d267f431969c515255e7.tar
patches-6090b6c47423e54b7929d267f431969c515255e7.tar.gz
gnu: Add texlive-pstool.
* gnu/packages/tex.scm (texlive-pstool): New variable. (texlive-latex-pstool): Deprecate package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 11 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 62db2619f5..1f2f223a81 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3978,32 +3978,15 @@ package options. A specialized system for setting @code{PSTricks} keys is
provided by the @code{pst-xkey} package.")
(license license:lppl1.3+)))
-(define-public texlive-latex-pstool
+(define-public texlive-pstool
(package
- (name "texlive-latex-pstool")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/pstool"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1h816jain8c9nky75kk8pmmwj5b4yf9dpqvdvi2l6jhfj5iqkzr8"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/pstool")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (inherit (simple-texlive-package
+ "texlive-pstool"
+ (list "/doc/latex/pstool/"
+ "/tex/latex/pstool/")
+ (base32
+ "12clzcw2cl7g2chr2phgmmiwxw4859cln1gbx1wgp8bl9iw590nc")
+ #:trivial? #t))
(propagated-inputs
`(("texlive-latex-bigfoot" ,texlive-latex-bigfoot) ; for suffix
("texlive-latex-filemod" ,texlive-latex-filemod)
@@ -4024,6 +4007,9 @@ drastically speeding up compilation time when only a single figure needs
re-processing.")
(license license:lppl)))
+(define-public texlive-latex-pstool
+ (deprecated-package "texlive-latex-pstool" texlive-pstool))
+
(define-public texlive-latex-seminar
(package
(name "texlive-latex-seminar")