summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-08-05 18:34:51 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-08-07 12:08:58 +0200
commit1335167a3bbb87ffc200d5f106b9a40e9bd4b90b (patch)
treedf00fd233a837c50baa06b16c7335aa0ca71ee61 /gnu/packages/tex.scm
parent149f66882125fbf656f194690f6178dfcc8104a1 (diff)
downloadpatches-1335167a3bbb87ffc200d5f106b9a40e9bd4b90b.tar
patches-1335167a3bbb87ffc200d5f106b9a40e9bd4b90b.tar.gz
gnu: biber: Update to 2.7.
* gnu/packages/tex.scm (biber)[name]: Rename to 'biber'. (biber-2.5): Remove variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 60b4a837b3..db08ed8643 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4058,7 +4058,7 @@ values (strings, macros, or numbers) pasted together.")
(define-public biber
(package
- (name "biber-next")
+ (name "biber")
(version "2.7")
(source (origin
(method url-fetch)
@@ -4136,33 +4136,6 @@ values (strings, macros, or numbers) pasted together.")
other things it comes with full Unicode support.")
(license license:artistic2.0)))
-;; Our version of texlive comes with biblatex 3.4, which is only compatible
-;; with biber 2.5 according to the compatibility matrix in the biber
-;; documentation.
-(define-public biber-2.5
- (package (inherit biber)
- (name "biber")
- (version "2.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/plk/biber/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "163sd343wkrzwnvj2003m2j0kz517jmjr4savw6f8bjxhj8fdrqv"))))
- (arguments
- (substitute-keyword-arguments (package-arguments biber)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'check 'delete-failing-test
- (lambda _
- (delete-file "t/sort-order.t")
- #t))))))
- (inputs
- `(("perl-date-simple" ,perl-date-simple)
- ,@(package-inputs biber)))))
-
(define-public rubber
(package
(name "rubber")