summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-14 23:00:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:48 +0200
commit1333198da836b5423a903fc618b0c512c859486c (patch)
tree485e52af9d19743c8290684595346616c9ee6bce /gnu/packages/tex.scm
parentc97d1a9123129e4b5bb6cc221c0ced1fb6271f8c (diff)
downloadpatches-1333198da836b5423a903fc618b0c512c859486c.tar
patches-1333198da836b5423a903fc618b0c512c859486c.tar.gz
gnu: Add texlive-filemod.
* gnu/packages/tex.scm (texlive-filemod): New variable. (texlive-latex-filemod): Deprecate package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 12 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 45ccdeb070..62db2619f5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3853,32 +3853,16 @@ without affecting the structure of the list (this works for @code{itemize} and
@code{enumerate} lists, and numbered lists remain in sequence).")
(license license:lppl)))
-(define-public texlive-latex-filemod
+(define-public texlive-filemod
(package
- (name "texlive-latex-filemod")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/filemod"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0vpxilfw69xv78f03g0j0zw0bw4qcn36whqp8phcq48qk1ax2kr2"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/filemod")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (inherit (simple-texlive-package
+ "texlive-filemod"
+ (list "/doc/latex/filemod/"
+ "/tex/latex/filemod/"
+ "/tex/generic/filemod/")
+ (base32
+ "1snsj7kblkj1ig3x3845lsypz7ab04lf0dcpdh946xakgjnz4fb5")
+ #:trivial? #t))
(home-page "https://www.ctan.org/pkg/filemod")
(synopsis "Provide file modification times, and compare them")
(description
@@ -3892,6 +3876,9 @@ mode. The functionality is provided by purely expandable macros or by faster
but non-expandable ones.")
(license license:lppl1.3+)))
+(define-public texlive-latex-filemod
+ (deprecated-package "texlive-latex-filemod" texlive-filemod))
+
(define-public texlive-latex-ifplatform
(package
(name "texlive-latex-ifplatform")