summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 12:05:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:17 +0200
commit5a1ee7d83556599b004ad6cf5561ae3c97b0e125 (patch)
tree3445cec1cad7d5d82841e1ad7903d11937c46213 /gnu/packages/tex.scm
parentf3540dbd47cff3a4cd4898afa2094b758b1d5f85 (diff)
downloadpatches-5a1ee7d83556599b004ad6cf5561ae3c97b0e125.tar
patches-5a1ee7d83556599b004ad6cf5561ae3c97b0e125.tar.gz
gnu: Add texlive-latex-pstool.
* gnu/packages/tex.scm (texlive-latex-pstool): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8d786b452a..0d44a89180 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1956,6 +1956,41 @@ with a user specified LaTeX construction, properly aligned, scaled, and/or
rotated.")
(license (license:fsf-free "file://psfrag.dtx"))))
+(define-public texlive-latex-pstool
+ (package
+ (name "texlive-latex-pstool")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "pstool"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1kwlk1x67lad4xb7gpkxqgdlxwpi6nvq1r9wika7m92abmyf18h3"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/pstool"
+ #:tex-format "latex"))
+ (inputs
+ `(("texlive-fonts-cm" ,texlive-fonts-cm)
+ ("texlive-latex-filecontents" ,texlive-latex-filecontents)))
+ (propagated-inputs
+ `(("texlive-latex-bigfoot" ,texlive-latex-bigfoot)
+ ("texlive-latex-filemod" ,texlive-latex-filemod)
+ ("texlive-latex-graphics" ,texlive-latex-graphics)
+ ("texlive-latex-ifplatform" ,texlive-latex-ifplatform)
+ ("texlive-latex-oberdiek" ,texlive-latex-oberdiek)
+ ("texlive-latex-psfrag" ,texlive-latex-psfrag)
+ ("texlive-latex-trimspaces" ,texlive-latex-trimspaces)))
+ (home-page "http://www.ctan.org/pkg/pstool")
+ (synopsis "Process PostScript graphisc within pdfLaTeX documents")
+ (description
+ "This is a package for processing PostScript graphics with @code{psfrag}
+labels within pdfLaTeX documents. Every graphic is compiled individually,
+drastically speeding up compilation time when only a single figure needs
+re-processing.")
+ (license license:lppl)))
+
(define-public texlive-latex-seminar
(package
(name "texlive-latex-seminar")