summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 12:04:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:16 +0200
commit8c23f238e9563fafc9cd06d52717bdb2a2cbfe65 (patch)
tree7d3b616e6e6b5d6de6f96a47d3b6935e3ecb5597 /gnu/packages/tex.scm
parent893e3fc1c091fef89ed88f1aa87bd74814cdda08 (diff)
downloadpatches-8c23f238e9563fafc9cd06d52717bdb2a2cbfe65.tar
patches-8c23f238e9563fafc9cd06d52717bdb2a2cbfe65.tar.gz
gnu: Add texlive-latex-ifplatform.
* gnu/packages/tex.scm (texlive-latex-ifplatform): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f54b8408ee..1a1bfdf31a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1883,6 +1883,31 @@ mode. The functionality is provided by purely expandable macros or by faster
but non-expandable ones.")
(license license:lppl1.3+)))
+(define-public texlive-latex-ifplatform
+ (package
+ (name "texlive-latex-ifplatform")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "ifplatform"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "11gvvjvmdfs9b7mm19yf80zwkx49jqcbq6g8qb9y5ns1r1qvnixp"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/ifplatform"))
+ (home-page "http://www.ctan.org/pkg/ifplatform")
+ (synopsis "Conditionals to test which platform is being used")
+ (description
+ "This package uses the (La)TeX extension @code{-shell-escape} to
+establish whether the document is being processed on a Windows or on a
+Unix-like system, or on Cygwin (Unix environment over a Windows system).
+Booleans provided are: @code{\\ifwindows}, @code{\\iflinux}, @code{\\ifmacosx}
+and @code{\\ifcygwin}. The package also preserves the output of @code{uname}
+on a Unix-like system, which may be used to distinguish between various
+classes of systems.")
+ (license license:lppl)))
+
(define-public texlive-latex-natbib
(package
(name "texlive-latex-natbib")