summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 22:46:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:12 +0200
commit7cda03bd87e7760cb6f23c23a746a1fc2499de10 (patch)
tree23864ad9eecdccdf6cf97a96aec6a856ea84ff65 /gnu/packages/tex.scm
parent8e732b49947ac22bb4f61458d794c2ab43cec754 (diff)
downloadpatches-7cda03bd87e7760cb6f23c23a746a1fc2499de10.tar
patches-7cda03bd87e7760cb6f23c23a746a1fc2499de10.tar.gz
gnu: Add texlive-latex-dinbrief.
* gnu/packages/tex.scm (texlive-latex-dinbrief): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ea27e1f9f9..dedd286728 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1649,6 +1649,39 @@ the @code{latin} option provides a short \"lorem ipsum\" (for a fuller \"lorem
ipsum\" text, see the @code{lipsum} package).")
(license license:lppl)))
+(define-public texlive-latex-dinbrief
+ (package
+ (name "texlive-latex-dinbrief")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "dinbrief"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0lb0kiy8fxzl6cnhcw1sggy6jrjvcd6kj1kkw3k9lkimm388yjz6"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/dinbrief"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-generated-file
+ (lambda _
+ (delete-file "dinbrief.drv")
+ #t)))))
+ (home-page "http://www.ctan.org/pkg/dinbrief")
+ (synopsis "German letter DIN style")
+ (description
+ "This package implements a document layout for writing letters according
+to the rules of DIN (Deutsches Institut für Normung, German standardisation
+institute). A style file for LaTeX 2.09 (with limited support of the
+features) is part of the package. Since the letter layout is based on a
+German standard, the user guide is written in German, but most macros have
+English names from which the user can recognize what they are used for. In
+addition there are example files showing how letters may be created with the
+package.")
+ (license license:lppl)))
+
(define-public texlive-latex-natbib
(package
(name "texlive-latex-natbib")