summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 08:53:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:15 +0200
commit63ed869bdd785f6a05b0ea287cc0637ecfbc6f6f (patch)
treec2210a8bc071acb234c58d40e7699458e4a532fd /gnu/packages/tex.scm
parent3966ebbbe75fb78c3fbdfcf0bb78920abdcef5d7 (diff)
downloadpatches-63ed869bdd785f6a05b0ea287cc0637ecfbc6f6f.tar
patches-63ed869bdd785f6a05b0ea287cc0637ecfbc6f6f.tar.gz
gnu: Add texlive-latex-wrapfig.
* gnu/packages/tex.scm (texlive-latex-wrapfig): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 432d10d640..92bfd85fca 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3169,6 +3169,40 @@ lasy font set and other odds and ends. The wasysym package implements an easy
to use interface for these symbols.")
(license license:lppl)))
+(define-public texlive-latex-wrapfig
+ (package
+ (name "texlive-latex-wrapfig")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/wrapfig"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "16xpyl0csmmwndz1xhzqfg9l0zcsnqxslsixsqkwd4zsvfj30sv4"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/wrapfig")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/wrapfig")
+ (synopsis "Produces figures which text can flow around")
+ (description
+ "This package allows figures or tables to have text wrapped around them.
+It does not work in combination with list environments, but can be used in a
+@code{parbox} or @code{minipage}, and in two-column format.")
+ (license license:lppl)))
+
(define-public texlive-latex-ucs
(package
(name "texlive-latex-ucs")