summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 08:53:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:15 +0200
commit3966ebbbe75fb78c3fbdfcf0bb78920abdcef5d7 (patch)
tree38b6f6fc7b76ecbab91bbe7c25db47eeb078de20 /gnu/packages/tex.scm
parente3088297f1230868d3d54efb36916c6305b2b3fa (diff)
downloadpatches-3966ebbbe75fb78c3fbdfcf0bb78920abdcef5d7.tar
patches-3966ebbbe75fb78c3fbdfcf0bb78920abdcef5d7.tar.gz
gnu: Add texlive-latex-varwidth.
* gnu/packages/tex.scm (texlive-latex-varwidth): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a5810eb61..432d10d640 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3114,6 +3114,40 @@ technical illustrations. Its output is scalable PostScript or SVG, rather
than the bitmaps Metafont creates.")
(license license:lppl)))
+(define-public texlive-latex-varwidth
+ (package
+ (name "texlive-latex-varwidth")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/varwidth"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1bmz9ap0ffyg7qry2xi7lki06qx4809w028xvk88cl66h7p46g52"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/varwidth")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/varwidth")
+ (synopsis "Variable-width minipage")
+ (description
+ "The @code{varwidth} environment is superficially similar to
+@code{minipage}, but the specified width is just a maximum value — the box may
+get a narrower “natural” width.")
+ (license license:lppl)))
+
(define-public texlive-latex-wasysym
(package
(name "texlive-latex-wasysym")