summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-10 08:32:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:13 +0200
commit17dce7e5d6e95093d6ca9b8ed462abf4cc92c144 (patch)
tree7e3616664b7bec13c6f57b2be5404302bdf11114 /gnu/packages/tex.scm
parent32e623d0d7ddf2be1756bf176b9ff3e8ac94b859 (diff)
downloadpatches-17dce7e5d6e95093d6ca9b8ed462abf4cc92c144.tar
patches-17dce7e5d6e95093d6ca9b8ed462abf4cc92c144.tar.gz
gnu: Add texlive-latex-fncychap.
* gnu/packages/tex.scm (texlive-latex-fncychap): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9e819e8ad0..ec6b6cd685 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1815,6 +1815,41 @@ recent classes such as powerdot or beamer, both of which are tuned to
21st-century presentation styles.")
(license license:lppl1.2+)))
+(define-public texlive-latex-fncychap
+ (package
+ (name "texlive-latex-fncychap")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/fncychap"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0fdk84dbicfjfprkz6vk15x36mvlhaw9isjmgkc56jp2khwjswwq"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/fncychap")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/fncychap")
+ (synopsis "Seven predefined chapter heading styles")
+ (description
+ "This package provides seven predefined chapter heading styles. Each
+style can be modified using a set of simple commands. Optionally one can
+modify the formatting routines in order to create additional chapter
+headings.")
+ (license license:lppl1.3+)))
+
(define-public texlive-latex-g-brief
(package
(name "texlive-latex-g-brief")