summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-10 08:31:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:13 +0200
commit32e623d0d7ddf2be1756bf176b9ff3e8ac94b859 (patch)
tree2437c335116169423306fe8f95f6a94d39fb88fd /gnu/packages/tex.scm
parentadfa7a2a8e54c5d890bcf205d9f0e3901e578604 (diff)
downloadpatches-32e623d0d7ddf2be1756bf176b9ff3e8ac94b859.tar
patches-32e623d0d7ddf2be1756bf176b9ff3e8ac94b859.tar.gz
gnu: Add texlive-latex-expdlist.
* gnu/packages/tex.scm (texlive-latex-expdlist): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82914d3846..9e819e8ad0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1734,6 +1734,37 @@ for a variety of alignment purposes, as is evidenced by the examples in
also provided.")
(license license:lppl1.3+)))
+(define-public texlive-latex-expdlist
+ (package
+ (name "texlive-latex-expdlist")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "expdlist"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1x7byk6x10njir3y9rm56glhdzrxwqag7gsnw2sqn1czlq525w7r"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/expdlist"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-generated-file
+ (lambda _
+ (for-each delete-file
+ (find-files "." "\\.drv$"))
+ #t)))))
+ (home-page "http://www.ctan.org/pkg/expdlist")
+ (synopsis "Expanded description environments")
+ (description
+ "The package provides additional features for the LaTeX
+@code{description} environment, including adjustable left margin. The package
+also allows the user to \"break\" a list (for example, to interpose a comment)
+without affecting the structure of the list (this works for @code{itemize} and
+@code{enumerate} lists, and numbered lists remain in sequence).")
+ (license license:lppl)))
+
(define-public texlive-latex-natbib
(package
(name "texlive-latex-natbib")