summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-27 20:14:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-27 21:35:41 -0400
commite3cfef22c4a18cacf33356a70788503fd689b96d (patch)
tree86549770a7be082dd83e0576511a3607a0b89f31 /gnu/packages/tex.scm
parent6715e1c24f19a5e1eb39c9baae9eebf4238533a7 (diff)
downloadpatches-e3cfef22c4a18cacf33356a70788503fd689b96d.tar
patches-e3cfef22c4a18cacf33356a70788503fd689b96d.tar.gz
gnu: Use invoke and return #t from all builders.
* gnu/packages/admin.scm, gnu/packages/android.scm, gnu/packages/audio.scm, gnu/packages/avr.scm, gnu/packages/base.scm, gnu/packages/bioinformatics.scm, gnu/packages/certs.scm, gnu/packages/check.scm, gnu/packages/code.scm, gnu/packages/commencement.scm, gnu/packages/dictionaries.scm, gnu/packages/docbook.scm, gnu/packages/emacs.scm, gnu/packages/embedded.scm, gnu/packages/fonts.scm, gnu/packages/games.scm, gnu/packages/gnome.scm, gnu/packages/gnu-doc.scm, gnu/packages/guile.scm, gnu/packages/hurd.scm, gnu/packages/javascript.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lxde.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/mate.scm, gnu/packages/pkg-config.scm, gnu/packages/qt.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/sdl.scm, gnu/packages/statistics.scm, gnu/packages/syncthing.scm, gnu/packages/tex.scm, gnu/packages/web.scm, gnu/packages/wine.scm, gnu/packages/xfce.scm: In the builders of packages using 'trivial-build-system', use invoke where appropriate, raise exceptions on errors, and otherwise return #t.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8279e9ce32..c48987ac53 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3519,9 +3519,10 @@ TeX metrics (VF and TFM files) and macros for use with LaTeX.")
"/share/texmf-dist/"))
(unzip (string-append (assoc-ref %build-inputs "unzip")
"/bin/unzip")))
- (system* unzip (assoc-ref %build-inputs "source"))
+ (invoke unzip (assoc-ref %build-inputs "source"))
(mkdir-p target)
- (copy-recursively "iwona" target)))))
+ (copy-recursively "iwona" target)
+ #t))))
(native-inputs
`(("unzip" ,unzip)))
(home-page "http://jmn.pl/en/kurier-i-iwona/")
@@ -4021,7 +4022,8 @@ This package contains the complete tree of texmf-dist data.")
(for-each
(lambda (name)
(symlink (string-append texmf "/share/" name) name))
- '("texmf-dist" "texmf-var"))))))))
+ '("texmf-dist" "texmf-var"))))
+ #t))))
(synopsis "TeX Live, a package of the TeX typesetting system")
(description
"TeX Live provides a comprehensive TeX document production system.