summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-08-14 10:54:05 +0200
committerLeo Famulari <leo@famulari.name>2018-08-16 16:53:26 -0400
commit7d50dff34c4e3b57b27e10d4feeb8d564ad09d15 (patch)
tree5ee82d8b970d52b33c20a9c0152f8f582c1a9f94 /gnu/packages/tex.scm
parentb42592db6ac6f71373b61c93ae87a548afce87b4 (diff)
downloadpatches-7d50dff34c4e3b57b27e10d4feeb8d564ad09d15.tar
patches-7d50dff34c4e3b57b27e10d4feeb8d564ad09d15.tar.gz
gnu: Add texlive-latex-media9.
* gnu/packages/tex.scm (texlive-latex-media9): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4a0a4faccb..555971b9ec 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4386,3 +4386,43 @@ cross-references, bibliographies, indexes, etc. It is very good for working
with documents of any length in which the usual processing abilities are
required: automatic sectioning and pagination, spell checking and so forth.")
(license license:gpl2+)))
+
+(define-public texlive-latex-media9
+ (package
+ (name "texlive-latex-media9")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/media9"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "01ysky8h8s6q12dxfahkzwhbkc9j5wl50xzcczy0cbjx9f6aj9kv"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/media9")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "https://www.ctan.org/pkg/media9")
+ (synopsis "Multimedia inclusion package with Adobe Reader-9/X compatibility")
+ (description
+ "The package provides an interface to embed interactive Flash (SWF) and 3D
+objects (Adobe U3D & PRC), as well as video and sound files or streams in the
+popular MP4, FLV and MP3 formats into PDF documents with Acrobat-9/X
+compatibility. Playback of multimedia files uses the built-in Flash Player of
+Adobe Reader and does, therefore, not depend on external plug-ins. Flash Player
+supports the efficient H.264 codec for video compression.
+
+The package is based on the RichMedia Annotation, an Adobe addition to the PDF
+specification. It replaces the now obsolete @code{movie15} package.")
+ (license license:lppl)))