summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-11 17:12:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-12 04:05:29 +0100
commitb3701ca198684b318d3ff632616ae1158534b491 (patch)
tree36f65e0e431ac7a7a99cac7ce47288e7a491c20a /gnu/packages/tex.scm
parent3306784a29302c65b45df18b7c1d3ad594d6c27b (diff)
downloadpatches-b3701ca198684b318d3ff632616ae1158534b491.tar
patches-b3701ca198684b318d3ff632616ae1158534b491.tar.gz
gnu: lyx: Use Python 3.
* gnu/packages/tex.scm (lyx)[inputs, native-inputs]: Replace python-2 with default python.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1eb4706405..6df3917920 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6303,17 +6303,14 @@ and Karl Berry.")
("hunspell" ,hunspell) ; Note: Could also use aspell instead.
("libx11" ,libx11)
("mythes" ,mythes)
- ("python" ,python-2)
+ ("python" ,python)
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
("zlib" ,zlib)))
(propagated-inputs
`(("texlive" ,(texlive-union (list texlive-fonts-ec)))))
- ;; FIXME: Python 3.7.0 cannot be used because the test infrastructure
- ;; "requires a bytes-like object, not 'str'". This may be fixed with
- ;; upgrades to Python.
(native-inputs
- `(("python-2" ,python-2)
+ `(("python" ,python)
("pkg-config" ,pkg-config)))
(home-page "https://www.lyx.org/")
(synopsis "Document preparation system with GUI")