summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-01 19:21:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-01 23:31:08 +0100
commit96f5377d5e0fe3481bbcc3d3e0e8d496c3ea5a24 (patch)
treef553fcd8b51f71adca5df00fef9dc53c813c3134 /gnu/packages/tex.scm
parent5e9bf5a2e0602601c3b6c3756d5b05a7fc1a212a (diff)
downloadpatches-96f5377d5e0fe3481bbcc3d3e0e8d496c3ea5a24.tar
patches-96f5377d5e0fe3481bbcc3d3e0e8d496c3ea5a24.tar.gz
gnu: texlive-fonts-knuth-lib: Build all tfm files.
* gnu/packages/tex.scm (texlive-fonts-knuth-lib)[arguments]: Build all tfm files in "build" phase.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bb76c48b66..738d49d7c7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -892,13 +892,17 @@ Computers & Typesetting series.")
(string-append (getcwd) ":"
mf "/share/texmf-dist/metafont/base")))
(mkdir "build")
- (invoke "mf" "-progname=mf"
- "-output-directory=build"
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "batchmode; "
- "input manfnt"))))
+ (for-each (lambda (font)
+ (format #t "building font ~a\n" font)
+ (invoke "mf" "-progname=mf"
+ "-output-directory=build"
+ (string-append "\\"
+ "mode:=ljfour; "
+ "mag:=1; "
+ "batchmode; "
+ "input " font)))
+ (find-files "." "(manfnt|logo.+)\\.mf$"))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))