summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-31 23:32:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-31 23:32:56 +0100
commit0747328e317de4bf936fab50e795d1e1523adfc1 (patch)
tree291d4f07a801b147d64faec31e4394c5cd46ce35 /gnu/packages/tex.scm
parentdf09e1d6e71f68a8fb44bcc9f13e625f9f9701a5 (diff)
parentff75441fcf0ba1212b0342f933a8999bafe60f03 (diff)
downloadpatches-0747328e317de4bf936fab50e795d1e1523adfc1.tar
patches-0747328e317de4bf936fab50e795d1e1523adfc1.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm78
1 files changed, 76 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2852b37676..5f294dc84c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2770,8 +2770,17 @@ re-processing.")
(sha256
(base32
"0y4i651b75y6006n03x8n86bsqvjsailvvz9bhzy51dzsznqidq0"))))
- (build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/seminar"))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/seminar")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
(home-page "https://www.ctan.org/pkg/seminar")
(synopsis "Make overhead slides")
;; TODO: This package may need fancybox and xcomment at runtime.
@@ -5806,3 +5815,68 @@ for use with LaTeX is available in @code{freenfss}, part of
supports advanced interactive documents. See the ConTeXt garden for a wealth
of support information.")
(license license:gpl2+)))
+
+(define-public texlive-latex-beamer
+ (package
+ (name "texlive-latex-beamer")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/beamer"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "09y3qwbj0nckshvg9afgwcv9v3zdif1d7bnpzrggsa1fbr80mgk2"))))
+ (build-system trivial-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/beamer"))
+ (docs (string-append (assoc-ref %outputs "doc")
+ "/share/texmf-dist/doc/latex/beamer/")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+
+ (mkdir-p docs)
+ (copy-recursively (assoc-ref %build-inputs "docs") docs)
+ #t))))
+ (propagated-inputs
+ `(("texlive-latex-hyperref" ,texlive-latex-hyperref)
+ ("texlive-latex-oberdiek" ,texlive-latex-oberdiek)
+ ("texlive-latex-etoolbox" ,texlive-latex-etoolbox)
+ ("texlive-latex-pgf" ,texlive-latex-pgf)))
+ (native-inputs
+ `(("docs"
+ ,(origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/doc/latex/beamer"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "102b18b9nw9dicqqgjwx0srh1mav8vh9wdvwayn741niza9hac23"))))))
+ (home-page "https://www.ctan.org/pkg/beamer")
+ (synopsis "LaTeX class for producing presentations and slides")
+ (description "The beamer LaTeX class can be used for producing slides.
+The class works in both PostScript and direct PDF output modes, using the
+@code{pgf} graphics system for visual effects. Content is created in the
+@code{frame} environment, and each frame can be made up of a number of slides
+using a simple notation for specifying material to appear on each slide within
+a frame. Short versions of title, authors, institute can also be specified as
+optional parameters. Whole frame graphics are supported by plain frames. The
+class supports @code{figure} and @code{table} environments, transparency
+effects, varying slide transitions and animations.")
+ ;; Code is dual licensed under GPLv2+ or LPPL1.3c+; documentation is
+ ;; dual-licensed under either FDLv1.3+ or LPPL1.3c+.
+ (license (list license:lppl1.3c+ license:gpl2+ license:fdl1.3+))))