summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
commit3b458d5462e6bbd852c2dc5c6670d5655abf53f5 (patch)
tree4f3ccec0de1c355134369333c17e948e3258d546 /gnu/packages/tex.scm
parent2ca3fdc2db1aef96fbf702a2f26f5e18ce832038 (diff)
parent14da3daafc8dd92fdabd3367694c930440fd72cb (diff)
downloadpatches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar
patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 22 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e42e910a78..a6fedd78f0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -102,21 +102,23 @@
(base32
"0khyi6h015r2zfqgg0a44a2j7vmr1cy42knw7jbss237yvakc07y"))
(patches
- (list
- ;; This is required for compatibility with Poppler 0.64.0 and to fix a
- ;; segmentation fault in dvipdfm-x from XeTeX, and also contains a fix
- ;; for CVE-2018-17407.
- (origin
- (method url-fetch)
- (uri (string-append "http://www.linuxfromscratch.org/patches/blfs/"
- "svn/texlive-" version "-source-upstream_fixes-2.patch"))
- (file-name "texlive-poppler-compat.patch")
- (sha256
- (base32
- "04sxy1qv9y575mxwyg3y7rx7mh540pfjqx7yni7ncb5wjbq9pq1a")))
- (search-patch "texlive-bin-luatex-poppler-compat.patch")
- (search-patch "texlive-bin-pdftex-poppler-compat.patch")
- (search-patch "texlive-bin-xetex-poppler-compat.patch")))))
+ (let ((arch-patch
+ (lambda (name revision hash)
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.archlinux.org/svntogit/packages.git"
+ "/plain/trunk/" name "?h=packages/texlive-bin"
+ "&id=" revision))
+ (file-name (string-append "texlive-bin-" name))
+ (sha256 (base32 hash)))))
+ (arch-revision "e1975bce0b9d270d7c9773c5beb7e87d61ee8f57"))
+ (append (search-patches "texlive-bin-CVE-2018-17407.patch"
+ "texlive-bin-luatex-poppler-compat.patch")
+ (list
+ (arch-patch "pdftex-poppler0.72.patch" arch-revision
+ "0p46b6xxxg2s3hx67r0wpz16g3qygx65hpc581xs3jz5pvsiq3y7")
+ (arch-patch "xetex-poppler-fixes.patch" arch-revision
+ "1jj1p5zkjljb7id9pjv29cw0cf8mwrgrh4ackgzz9c200vaqpsvx")))))))
(build-system gnu-build-system)
(inputs
`(("texlive-extra-src" ,texlive-extra-src)
@@ -195,9 +197,9 @@
#t))
(add-after 'unpack 'use-code-for-new-poppler
(lambda _
- (copy-file "texk/web2c/pdftexdir/pdftoepdf-newpoppler.cc"
+ (copy-file "texk/web2c/pdftexdir/pdftoepdf-poppler0.72.0.cc"
"texk/web2c/pdftexdir/pdftoepdf.cc")
- (copy-file "texk/web2c/pdftexdir/pdftosrc-newpoppler.cc"
+ (copy-file "texk/web2c/pdftexdir/pdftosrc-poppler0.72.0.cc"
"texk/web2c/pdftexdir/pdftosrc.cc")
#t))
(add-after 'use-code-for-new-poppler 'use-code-for-even-newer-poppler
@@ -3425,8 +3427,8 @@ command.")
(description
"Identify areas of text to be marked with changebars with the
@code{\\cbstart} and @code{\\cbend} commands; the bars may be coloured. The
-package uses 'drivers' to place the bars; the available drivers can work with
-@code{dvitoln03}, @code{dvitops}, @code{dvips}, the emTeX and TeXtures DVI
+package uses @code{drivers} to place the bars; the available drivers can work
+with @code{dvitoln03}, @code{dvitops}, @code{dvips}, the emTeX and TeXtures DVI
drivers, and VTeX and pdfTeX.")
(license license:lppl)))
@@ -6029,7 +6031,7 @@ typearea (which are the main parts of the bundle).")
(copy-recursively (assoc-ref %build-inputs "source") target)
#t))))
(home-page "https://www.ctan.org/pkg/listofitems")
- (synopsis "Grab items in lists using user-specified seperation character")
+ (synopsis "Grab items in lists using user-specified separation character")
(description
"This package allows one to capture all the items of a list, for which
the parsing character has been selected by the user, and to access any of