summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-05 22:24:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-05 22:45:42 +0200
commit11ecf9f48f53b3263240e714cf1de859a9db6149 (patch)
tree8adab88af9310268f408a006da8a9d9f47474671 /gnu/packages/tex.scm
parentf16e09487b94a14717f271a0067525bedba9dddc (diff)
downloadpatches-11ecf9f48f53b3263240e714cf1de859a9db6149.tar
patches-11ecf9f48f53b3263240e714cf1de859a9db6149.tar.gz
gnu: Add texlive-standalone.
* gnu/packages/tex.scm (texlive-standalone): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a6d6539e71..c5e36af064 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7270,3 +7270,32 @@ macros it defines for keys, and to define families of key definitions; these
all help use in documents where several packages define their own sets of
keys.")
(license license:lppl1.3+)))
+
+(define-public texlive-standalone
+ (package
+ (name "texlive-standalone")
+ (version (number->string %texlive-revision))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "standalone"))
+ (sha256
+ (base32
+ "192ydxcn8ir96q8qwvnppksmqf5i0p50i0wz6iqazbwmh3dqxpx4"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/standalone"))
+ (propagated-inputs
+ `(("texlive-latex-xkeyval" ,texlive-latex-xkeyval)))
+ (native-inputs
+ `(("texlive-ydoc" ,texlive-ydoc)))
+ (home-page "http://www.ctan.org/pkg/standalone")
+ (synopsis "Compile TeX pictures stand-alone or as part of a document")
+ (description "A class and package is provided which allows TeX pictures or
+other TeX code to be compiled standalone or as part of a main document.
+Special support for pictures with beamer overlays is also provided. The
+package is used in the main document and skips extra preambles in sub-files.
+The class may be used to simplify the preamble in sub-files. By default the
+@code{preview} package is used to display the typeset code without margins.
+The behaviour in standalone mode may adjusted using a configuration file
+@code{standalone.cfg} to redefine the standalone environment.")
+ (license license:lppl1.3+)))