summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2019-01-07 15:27:39 +0100
committerJelle Licht <jlicht@fsfe.org>2019-01-07 15:40:58 +0100
commit41a010875ba4108e666f11fc111cf5bb5dcf5464 (patch)
treef7cba9e940fc724713ad75939647bff47f797945 /gnu/packages/tex.scm
parent60a166c629f98d763c3bee66e3772e331ec4b351 (diff)
downloadpatches-41a010875ba4108e666f11fc111cf5bb5dcf5464.tar
patches-41a010875ba4108e666f11fc111cf5bb5dcf5464.tar.gz
gnu: biber: Update to 2.12.
* gnu/packages/tex.scm (biber): Update to 2.12. [source]: Use 'git-fetch'. Add patch. [inputs]: Add perl-file-slurper. Remove perl-file-slurp. * gnu/packages/patches/biber-fix-encoding-write.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 765f6aa849..3bfde1d714 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4219,15 +4219,19 @@ values (strings, macros, or numbers) pasted together.")
(define-public biber
(package
(name "biber")
- (version "2.7")
+ (version "2.12")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/plk/biber/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/plk/biber/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ ;; TODO: Patch awaiting inclusion upstream (see:
+ ;; https://github.com/plk/biber/issues/239).
+ (patches (search-patches "biber-fix-encoding-write.patch"))
(sha256
(base32
- "17wd80jg98qyddhvz4cin8779ycvppaf2va77r1lyvymjz6w9bx0"))))
+ "1g1hi6zvf2hmrjly1sidjaxy5440gfqm4p7p3n7kayshnjsmlskx"))))
(build-system perl-build-system)
(arguments
`(#:phases
@@ -4249,7 +4253,7 @@ values (strings, macros, or numbers) pasted together.")
("perl-data-uniqid" ,perl-data-uniqid)
("perl-datetime-format-builder" ,perl-datetime-format-builder)
("perl-datetime-calendar-julian" ,perl-datetime-calendar-julian)
- ("perl-file-slurp" ,perl-file-slurp)
+ ("perl-file-slurper" ,perl-file-slurper)
("perl-ipc-cmd" ,perl-ipc-cmd)
("perl-ipc-run3" ,perl-ipc-run3)
("perl-list-allutils" ,perl-list-allutils)