summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-14 23:13:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:48 +0200
commitfb01a2965a707bcf17f5949c3ba734f296fe8520 (patch)
treee11d07a9586db56121586b1c81f80bd18eb522e6 /gnu/packages/tex.scm
parenta72058b950c5a204806177fea8c74e20c71329b2 (diff)
downloadpatches-fb01a2965a707bcf17f5949c3ba734f296fe8520.tar
patches-fb01a2965a707bcf17f5949c3ba734f296fe8520.tar.gz
gnu: Add texlive-doi.
* gnu/packages/tex.scm (texlive-doi): New variable. (texlive-latex-doi): Deprecate package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 11 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 65cb38e93a..3361e9845e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4100,32 +4100,15 @@ space-stripped macros.")
to something that's not a float.")
(license license:lppl)))
-(define-public texlive-latex-doi
+(define-public texlive-doi
(package
- (name "texlive-latex-doi")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/doi"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0378rdmrgr2lzbfi4qqy4dfpj5im20diyd8z8b9m4mlg05r7wgnb"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/doi")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (inherit (simple-texlive-package
+ "texlive-doi"
+ (list "/doc/latex/doi/README"
+ "/tex/latex/doi/")
+ (base32
+ "17lnnhfmb8g4nh4fnyc9616h8xg3vjrzmlvfmlfqwwlfpma9xnnw")
+ #:trivial? #t))
(home-page "https://www.ctan.org/pkg/doi")
(synopsis "Create correct hyperlinks for DOI numbers")
(description
@@ -4138,6 +4121,9 @@ hyperlink to the target of the DOI.")
;; Any version of the LPPL.
(license license:lppl1.3+)))
+(define-public texlive-latex-doi
+ (deprecated-package "texlive-latex-doi" texlive-doi))
+
(define-public texlive-latex-etoolbox
(package
(name "texlive-latex-etoolbox")