summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-05 22:12:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-05 22:45:41 +0200
commit73ce44218b8beb8e7f94777efb7bf500462cabf2 (patch)
tree58cce9b03668199147d9d1e9155ac638255b3a81 /gnu/packages/tex.scm
parent266e07421e6290f43c8269f9380327c2584db578 (diff)
downloadpatches-73ce44218b8beb8e7f94777efb7bf500462cabf2.tar
patches-73ce44218b8beb8e7f94777efb7bf500462cabf2.tar.gz
gnu: Add texlive-ydoc.
* gnu/packages/tex.scm (texlive-ydoc): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7838b16b1d..7b040ab7c7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7068,3 +7068,51 @@ the file to which it applies.")
"This package helps LaTeX users to create PDF/X, PFD/A and other
standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
(license license:lppl1.2+)))
+
+(define-public texlive-ydoc
+ (let ((template (simple-texlive-package
+ "texlive-ydoc"
+ (list "/doc/latex/ydoc/"
+ "/source/latex/ydoc/")
+ (base32
+ "0ckcpy1b8v1fk3qc8qkxgiag2wc0qzxm6bgksv000m4m1hsi2g8b")
+ #:trivial? #f)))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/ydoc")
+ ((#:build-targets _ #t)
+ ''("ydoc.dtx"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/ydoc") #t))
+ (add-after 'copy-files 'move-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((share (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist"))
+ (target (string-append share "/tex/generic/ydoc"))
+ (doc (string-append (assoc-ref outputs "doc")
+ "/share/texmf-dist/doc") ))
+ (mkdir-p target)
+ (for-each
+ (lambda (file)
+ (rename-file (string-append share "/tex/latex/ydoc/" file)
+ (string-append target "/" file)))
+ '("ydocincl.tex" "ydocstrip.tex"))
+ (mkdir-p doc)
+ (rename-file (string-append share "/doc") doc)
+ #t)))))))
+ (home-page "http://www.ctan.org/pkg/ydoc")
+ (synopsis "Macros for documentation of LaTeX classes and packages")
+ (description "The package provides macros and environments to document
+LaTeX packages and classes. It is an (as yet unfinished) alternative to the
+@code{ltxdoc} class and the @code{doc} or @code{xdoc} packages. The aim is to
+provide a different layout and more modern styles (using the @code{xcolor},
+@code{hyperref} packages, etc.) This is an alpha release, and should probably
+not (yet) be used with other packages, since the implementation might
+change.")
+ (license license:lppl1.3+))))