summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 21:45:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:11 +0200
commit588b5e96119f0a988168a841b3b87938a724f8fa (patch)
tree1dcc46b06cbebd307f30261c05bba3b27edbf15e /gnu/packages/tex.scm
parent60b5e228c4fc0ecb3ee1c663789c7ca91485ab7d (diff)
downloadpatches-588b5e96119f0a988168a841b3b87938a724f8fa.tar
patches-588b5e96119f0a988168a841b3b87938a724f8fa.tar.gz
gnu: Add texlive-latex-g-brief.
* gnu/packages/tex.scm (texlive-latex-g-brief): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1d325c9e0a..94c75c0aec 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1674,6 +1674,35 @@ recent classes such as powerdot or beamer, both of which are tuned to
21st-century presentation styles.")
(license license:lppl1.2+)))
+(define-public texlive-latex-g-brief
+ (package
+ (name "texlive-latex-g-brief")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "g-brief"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0sikazkg0dpkcpzlbqw8qzxr81paf2f443vsrh14jnw7s4gswvc5"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/g-brief"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-generated-file
+ (lambda _
+ (delete-file "g-brief.drv")
+ #t)))))
+ (home-page "http://www.ctan.org/pkg/g-brief")
+ (synopsis "Letter document class")
+ (description
+ "This package is designed for formatting formless letters in German; it
+can also be used for English (by those who can read the documentation). There
+are LaTeX 2.09 @code{documentstyle} and LaTeX 2e class files for both an
+\"old\" and a \"new\" version of g-brief.")
+ (license license:lppl)))
+
(define-public texlive-latex-hyperref
(package
(name "texlive-latex-hyperref")