summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-08-06 16:26:49 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-08-07 12:29:20 +0200
commitc97fbf55e7fe6c6dcf5620032f602e2c55592d73 (patch)
treef444bd983bea321d492f5afe5f164dc0c8e4bfba /gnu/packages/tex.scm
parent1335167a3bbb87ffc200d5f106b9a40e9bd4b90b (diff)
downloadpatches-c97fbf55e7fe6c6dcf5620032f602e2c55592d73.tar
patches-c97fbf55e7fe6c6dcf5620032f602e2c55592d73.tar.gz
gnu: texlive: Remove texlive-minimal.
This package is superseded by the modular TeX Live distribution. * gnu/packages/tex.scm (texlive-minimal, texlive-texmf-minimal): Remove variables.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm75
1 files changed, 0 insertions, 75 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index db08ed8643..f12746c83f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3939,81 +3939,6 @@ This package contains the complete TeX Live distribution.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))
(home-page "https://www.tug.org/texlive/")))
-
-;; texlive-texmf-minimal is a pruned, small version of the texlive tree,
-;; in particular dropping documentation and fonts. It weighs in at 470 MiB
-;; instead of 4 GiB.
-(define texlive-texmf-minimal
- (package (inherit texlive-texmf)
- (name "texlive-texmf-minimal")
- (arguments
- (substitute-keyword-arguments
- (package-arguments texlive-texmf)
- ((#:modules modules)
- `((ice-9 ftw)
- (srfi srfi-1)
- ,@modules))
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'prune
- (lambda _
- (define (delete subdir exclude)
- "Delete all files and directories in SUBDIR except for those
-given in the list EXCLUDE."
- (with-directory-excursion subdir
- (for-each delete-file-recursively
- (lset-difference equal?
- (scandir ".")
- (append '("." "..")
- exclude)))))
- (with-directory-excursion "texmf-dist"
- (for-each delete-file-recursively
- '("doc" "source" "tex4ht"))
- ;; Delete all subdirectories of "fonts", except for "tfm" and
- ;; any directories named "cm".
- (delete "fonts" '("afm" "map" "pk" "source" "tfm" "type1"))
- (delete "fonts/afm" '("public"))
- (delete "fonts/afm/public" '("amsfonts"))
- (delete "fonts/afm/public/amsfonts" '("cm"))
- (delete "fonts/map" '("dvips"))
- (delete "fonts/map/dvips" '("cm"))
- (delete "fonts/source" '("public"))
- (delete "fonts/source/public" '("cm"))
- (delete "fonts/tfm" '("public"))
- (delete "fonts/type1" '("public"))
- (delete "fonts/type1/public" '("amsfonts"))
- (delete "fonts/type1/public/amsfonts" '("cm")))
- #t))))))
- (description
- "TeX Live provides a comprehensive TeX document production system.
-It includes all the major TeX-related programs, macro packages, and fonts
-that are free software, including support for many languages around the
-world.
-
-This package contains a small subset of the texmf-dist data.")))
-
-
-;; texlive-minimal is the same as texlive, but using texlive-texmf-minimal
-;; instead of the full texlive-texmf. It can be used, for instance, as a
-;; native input to packages that need texlive to build their documentation.
-(define-public texlive-minimal
- (package (inherit texlive)
- (name "texlive-minimal")
- (inputs
- `(("texlive-texmf" ,texlive-texmf-minimal)
- ,@(alist-delete "texlive-texmf" (package-inputs texlive))))
- (native-search-paths
- (list (search-path-specification
- (variable "TEXMFLOCAL")
- (files '("share/texmf-local")))))
- (description
- "TeX Live provides a comprehensive TeX document production system.
-It includes all the major TeX-related programs, macro packages, and fonts
-that are free software, including support for many languages around the
-world.
-
-This package contains a small working part of the TeX Live distribution.")))
-
(define-public perl-text-bibtex
(package
(name "perl-text-bibtex")