summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-14 22:56:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:48 +0200
commitc97d1a9123129e4b5bb6cc221c0ced1fb6271f8c (patch)
tree22ed8883644a01e705dba77b445dc3d9505403a9 /gnu/packages/tex.scm
parent152950d49499b5e15a4cff8307e0ebcc6d16e9e5 (diff)
downloadpatches-c97d1a9123129e4b5bb6cc221c0ced1fb6271f8c.tar
patches-c97d1a9123129e4b5bb6cc221c0ced1fb6271f8c.tar.gz
gnu: Add texlive-url.
* gnu/packages/tex.scm (texlive-url): New variable. (texlive-latex-url): Deprecate package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 11 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b2c072f694..45ccdeb070 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3003,32 +3003,15 @@ rawfonts, showkeys, somedefs, tabularx, theorem, trace, varioref, verbatim,
xr, and xspace.")
(license license:lppl1.3+)))
-(define-public texlive-latex-url
+(define-public texlive-url
(package
- (name "texlive-latex-url")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/url"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "184s2543cwia5l7iibhlkl1ffbncfhjpv5p56zq0c15by5sghlac"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/url")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (inherit (simple-texlive-package
+ "texlive-url"
+ (list "/doc/latex/url/"
+ "/tex/latex/url/")
+ (base32
+ "184m40wgnx939ky2hbxnj0v9aak023ldrhgffp0lgyk9wdqpxlqg")
+ #:trivial? #t))
(home-page "https://www.ctan.org/pkg/url")
(synopsis "Verbatim with URL-sensitive line breaks")
(description "The command @code{\\url} is a form of verbatim command that
@@ -3043,6 +3026,9 @@ of file names.")
;; the latest version is 1.3c.
(license license:lppl1.3c+)))
+(define-public texlive-latex-url
+ (deprecated-package "texlive-latex-url" texlive-url))
+
(define-public texlive-latex-l3kernel
(package
(name "texlive-latex-l3kernel")