summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:59:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:46 +0200
commit40b009b8c934144d005097f3a88b45bb5d5c0f3f (patch)
treed0450981bdc071a40fa06f596a604754bf6d33f5 /gnu/packages/tex.scm
parent3cd8868f321bb09da9974913d6d9550735406f32 (diff)
downloadpatches-40b009b8c934144d005097f3a88b45bb5d5c0f3f.tar
patches-40b009b8c934144d005097f3a88b45bb5d5c0f3f.tar.gz
gnu: Add texlive-hyphen-spanish.
* gnu/packages/tex.scm (texlive-hyphen-spanish): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bebe1c5be9..b2a4b90f84 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2172,6 +2172,21 @@ T1/EC and UTF-8 encodings.")
;; Either license
(license (list license:lppl1.0+ license:expat))))
+(define-public texlive-hyphen-spanish
+ (package
+ ;; The source files "eshyph-make.lua" and "eshyph.src" are provided to
+ ;; generate obsolete hyphenation patterns, which aren't included in a
+ ;; default TeX Live distribution, so we don't include them either.
+ (inherit (texlive-hyphen-package
+ "texlive-hyphen-spanish" "es"
+ (list "/tex/generic/hyph-utf8/patterns/tex/hyph-es.tex")
+ (base32
+ "0jgs0zzyk2wwrjbx2hqdh5qggrnik9xmsxygbfhlb7gdrcrs0mbj")))
+ (synopsis "Hyphenation patterns for Spanish")
+ (description "The package provides hyphenation patterns for Spanish in
+T1/EC and UTF-8 encodings.")
+ (license license:expat)))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package