summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 22:36:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:12 +0200
commit8e732b49947ac22bb4f61458d794c2ab43cec754 (patch)
treed01ef13f7f9e82334d4b5c54e3b6820f6969b6f7 /gnu/packages/tex.scm
parent80bf1f21381df74ac0c693faeddbbb4a7b093549 (diff)
downloadpatches-8e732b49947ac22bb4f61458d794c2ab43cec754.tar
patches-8e732b49947ac22bb4f61458d794c2ab43cec754.tar.gz
gnu: Add texlive-latex-blindtext.
* gnu/packages/tex.scm (texlive-latex-blindtext): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e29c8212e9..ea27e1f9f9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1624,6 +1624,31 @@ make direct processing by LaTeX easier. The package can be used either in
conjunction with BibTeX or as a replacement for BibTeX.")
(license license:lppl1.3+)))
+(define-public texlive-latex-blindtext
+ (package
+ (name "texlive-latex-blindtext")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "blindtext"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1jrja9b1pzdh9zgv1jh807w4xijqja58n2mqny6dkwicv8qfgbfg"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/blindtext"))
+ (home-page "http://www.ctan.org/pkg/blindtext")
+ (synopsis "Producing 'blind' text for testing")
+ (description
+ "The package provides the commands @code{\\blindtext} and
+@code{\\Blindtext} for creating \"blind\" text useful in testing new classes
+and packages, and @code{\\blinddocument}, @code{\\Blinddocument} for creating
+an entire random document with sections, lists, mathematics, etc. The package
+supports three languages, @code{english}, @code{(n)german} and @code{latin};
+the @code{latin} option provides a short \"lorem ipsum\" (for a fuller \"lorem
+ipsum\" text, see the @code{lipsum} package).")
+ (license license:lppl)))
+
(define-public texlive-latex-natbib
(package
(name "texlive-latex-natbib")