summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-24 18:25:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 18:25:12 +0200
commitd350d5e71434704d147b1252d21e46daf6bb9885 (patch)
tree49e7abb95764b46516827d5aebd8e3e82b3526d3 /gnu/packages/tex.scm
parenta6405e0333fe371e8beb84121f01119401fd09e9 (diff)
downloadpatches-d350d5e71434704d147b1252d21e46daf6bb9885.tar
patches-d350d5e71434704d147b1252d21e46daf6bb9885.tar.gz
gnu: texlive-amsfonts: Build .ins file instead of installing fonts twice.
* gnu/packages/tex.scm (texlive-amsfonts)[arguments]: Override build targets; rename font build directory to avoid installing it a second time.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4e65de9391..5be86e7d9e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1045,6 +1045,8 @@ Taco Hoekwater.")
(inherit template)
(arguments
(substitute-keyword-arguments (package-arguments template)
+ ((#:build-targets _ #t)
+ '(list "amsfonts.ins"))
((#:tex-directory _ #t)
"latex/amsfonts")
((#:modules modules '())
@@ -1073,7 +1075,7 @@ Taco Hoekwater.")
mf "/share/texmf-dist/metafont/base:"
(assoc-ref inputs "texlive-cm")
"/share/texmf-dist/fonts/source/public/cm")))
- (let ((build (string-append (getcwd) "/build")))
+ (let ((build (string-append (getcwd) "/build-fonts")))
(mkdir-p build)
(with-directory-excursion "fonts/source/public/amsfonts"
(for-each (lambda (font)
@@ -1092,7 +1094,7 @@ Taco Hoekwater.")
;; There are no metafont sources for the Euler fonts, so we
;; convert the afm files instead.
- (let ((build (string-append (getcwd) "/build/euler")))
+ (let ((build (string-append (getcwd) "/build-fonts/euler")))
(mkdir build)
(with-directory-excursion "fonts/afm/public/amsfonts/"
(for-each (lambda (font)
@@ -1107,9 +1109,10 @@ Taco Hoekwater.")
;; eufm10.afm to eufm8.pl, and then generate the tfm file from
;; the pl file.
(setenv "TEXINPUTS"
- (string-append build "//:"
- (getcwd) "/fonts/afm/public/amsfonts//:"
- (assoc-ref inputs "texlive-union") "//"))
+ (string-append build "//:"
+ (getcwd) "/fonts/afm/public/amsfonts//:"
+ (getcwd) "/source/latex/amsfonts//:"
+ (assoc-ref inputs "texlive-union") "//"))
(with-directory-excursion build
(for-each (match-lambda
(((target-base target-size)
@@ -1148,7 +1151,7 @@ Taco Hoekwater.")
#t))
(add-after 'install 'install-generated-fonts
(lambda* (#:key inputs outputs #:allow-other-keys)
- (copy-recursively "build"
+ (copy-recursively "build-fonts"
(string-append
(assoc-ref outputs "out")
"/share/texmf-dist/fonts/tfm/public/amsfonts"))