summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 12:03:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:16 +0200
commit74e9c9a46307a2e2de775ee4a32a53379a03284a (patch)
tree388230f1c39cffa0cf954caad5bde7c19f7a3c8e /gnu/packages/tex.scm
parent3236599f50ebcb1c2355a3c9f687720fa2f54005 (diff)
downloadpatches-74e9c9a46307a2e2de775ee4a32a53379a03284a.tar
patches-74e9c9a46307a2e2de775ee4a32a53379a03284a.tar.gz
gnu: Add texlive-latex-environ.
* gnu/packages/tex.scm (texlive-latex-environ): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c4314cde5d..4c3d15419e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1764,6 +1764,28 @@ implementation is output device independent, and made very simple by relying
on everypage.")
(license license:lppl1.3+)))
+(define-public texlive-latex-environ
+ (package
+ (name "texlive-latex-environ")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "environ"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "06h28b26dyjkj9shksphgqfv4130jfkwhbw737hxn7d3yvdfffyd"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/environ"))
+ (home-page "http://www.ctan.org/pkg/environ")
+ (synopsis "New interface for environments in LaTeX")
+ (description
+ "This package provides the @code{\\collect@body} command (as in
+@code{amsmath}), as well as a @code{\\long} version @code{\\Collect@Body}, for
+collecting the body text of an environment. These commands are used to define
+a new author interface to creating new environments.")
+ (license license:lppl)))
+
(define-public texlive-latex-eqparbox
(package
(name "texlive-latex-eqparbox")