summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-11-17 04:08:33 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2017-11-17 13:28:08 +0300
commit669be6acfe119a6a9fef4d97a0c14d4adb67dca5 (patch)
treeb6c154f74ff7e1b71fab35d01bef52a0aa1959d7 /gnu/packages/terminals.scm
parent9bc646d0537a08676cb876179a328c1dfff091fc (diff)
downloadpatches-669be6acfe119a6a9fef4d97a0c14d4adb67dca5.tar
patches-669be6acfe119a6a9fef4d97a0c14d4adb67dca5.tar.gz
gnu: cool-retro-term: Fix qml path.
* gnu/packages/terminals.scm (cool-retro-term): Fix qml path.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 2f74c5d5b5..215511864a 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -493,7 +493,7 @@ embedded kernel situations.")
(share (string-append out "/share")))
(substitute* '("qmltermwidget/qmltermwidget.pro")
(("INSTALL_DIR = \\$\\$\\[QT_INSTALL_QML\\]")
- (string-append "INSTALL_DIR = " out "/qml")))
+ (string-append "INSTALL_DIR = " out "/lib/qt5/qml")))
(substitute* '("app/app.pro")
(("target.path \\+= /usr")
(string-append "target.path += " out))
@@ -514,7 +514,7 @@ embedded kernel situations.")
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (qml "/qml"))
+ (qml "/lib/qt5/qml"))
(wrap-program (string-append out "/bin/cool-retro-term")
`("QML2_IMPORT_PATH" ":" prefix
(,(string-append out qml)