summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-01 10:29:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-01 10:29:59 +0200
commit19b7bba1b5f115168b1669325cd51bc66b9dc4b4 (patch)
tree7b4e77080fe6fbc3a54b8612adc3c5c27ab81d05 /gnu/packages/terminals.scm
parentf37931d6632627a24e4eccafa1603ffadb649ff6 (diff)
parent5010d0e36452882eb95666467bb983efa8cca081 (diff)
downloadpatches-19b7bba1b5f115168b1669325cd51bc66b9dc4b4.tar
patches-19b7bba1b5f115168b1669325cd51bc66b9dc4b4.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 2fa5f7e4cd..1bfe6a7762 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;;
@@ -27,6 +28,7 @@
(define-module (gnu packages terminals)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build utils)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
@@ -51,6 +53,7 @@
#:use-module (gnu packages wm)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
#:use-module (srfi srfi-26))
(define-public tilda
@@ -537,3 +540,33 @@ eye-candy, customizable, and reasonably lightweight.")
license:silofl1.1
license:x11
license:bsd-3)))))
+
+(define-public sakura
+ (package
+ (name "sakura")
+ (version "3.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/" name "/trunk/"
+ version "/+download/" name "-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0fhcn3540iw22l5zg3njh5z8cj0g2n9p6fvagjqa5zc323jfsc7b"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; no check phase
+ '(#:tests? #f))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("perl" ,perl) ; for pod2man
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxft" ,libxft)
+ ("vte" ,vte)))
+ (home-page "https://launchpad.net/sakura")
+ (synopsis "A simple but powerful libvte-based terminal emulator")
+ (description "@code{Sakura} is a terminal emulator based on GTK+ and VTE.
+It's a terminal emulator with few dependencies, so you don't need a full GNOME
+desktop installed to have a decent terminal emulator.")
+ (license license:gpl2)))