summaryrefslogtreecommitdiff
path: root/gnu/packages/tcsh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-02 23:18:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-02 23:18:27 +0100
commite343024dc46a8f513e78eec3d756b0d9f8bfd6f6 (patch)
treee44ebfeb98f028b9ac70438476104e8b928c393e /gnu/packages/tcsh.scm
parent7e75a6739bf02c39baf8340e31e590c2c7c5fd16 (diff)
downloadpatches-e343024dc46a8f513e78eec3d756b0d9f8bfd6f6.tar
patches-e343024dc46a8f513e78eec3d756b0d9f8bfd6f6.tar.gz
gnu: tcsh: Use ISO-8859-1 when patching "tests/testsuite".
* gnu/packages/tcsh.scm (tcsh)[arguments]: Set %DEFAULT-PORT-ENCODING before substituting "tests/testsuite". Fixes build failure at <http://hydra.gnu.org/build/266962/nixlog/1/raw>.
Diffstat (limited to 'gnu/packages/tcsh.scm')
-rw-r--r--gnu/packages/tcsh.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/tcsh.scm b/gnu/packages/tcsh.scm
index f582713911..814f2a6321 100644
--- a/gnu/packages/tcsh.scm
+++ b/gnu/packages/tcsh.scm
@@ -58,7 +58,11 @@
(("; other_script.csh") "; /bin/sh other_script.csh"))
;; Now, let's generate the test suite and patch it
(system* "make" "tests/testsuite")
- (substitute* "tests/testsuite" (("/bin/sh") (which "sh"))))
+
+ ;; This file is ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "tests/testsuite"
+ (("/bin/sh") (which "sh")))))
(alist-cons-after
'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)