summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-13 07:30:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-13 07:30:13 +0100
commit1004a92c7201284a801e5c8be399e8852fc238be (patch)
tree1631ff65346f7ff53c6a899169d417c972df630c /gnu/packages/tcl.scm
parentf7c03e452b25b86123e0a9478fdb5541f259ddee (diff)
downloadpatches-1004a92c7201284a801e5c8be399e8852fc238be.tar
patches-1004a92c7201284a801e5c8be399e8852fc238be.tar.gz
gnu: tcl: Use 'modify-phases' syntax.
* gnu/packages/tcl.scm (tcl)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 01649ff410..8e94c67e47 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -48,24 +48,22 @@
"19bb09l55alz4jb38961ikd5116q80s51bjvzqy44ckkwf28ysvw"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'pre-configure
- (lambda _
- (chdir "unix"))
- (alist-cons-after
- 'install 'install-private-headers
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Private headers are needed by Expect.
- (and (zero? (system* "make"
- "install-private-headers"))
- (let ((bin (string-append (assoc-ref outputs "out")
- "/bin")))
- ;; Create a tclsh -> tclsh8.6 symlink.
- ;; Programs such as Ghostscript rely on it.
- (with-directory-excursion bin
- (symlink (car (find-files "." "tclsh"))
- "tclsh")))))
- %standard-phases))
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _ (chdir "unix") #t))
+ (add-after 'install 'install-private-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Private headers are needed by Expect.
+ (and (zero? (system* "make"
+ "install-private-headers"))
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ ;; Create a tclsh -> tclsh8.6 symlink.
+ ;; Programs such as Ghostscript rely on it.
+ (with-directory-excursion bin
+ (symlink (car (find-files "." "tclsh"))
+ "tclsh"))
+ #t)))))
;; By default, man pages are put in PREFIX/man, but we want them in
;; PREFIX/share/man. The 'validate-documentation-location' phase is