aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/synergy.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-19 15:01:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-19 15:01:00 +0100
commit2dd12924cf4a30a96262b6d392fcde58c9f10d4b (patch)
tree3f74f5426ff214a02b8f6652f6516979657a7f98 /gnu/packages/synergy.scm
parent259b4f34ba2eaefeafdb7c9f9eb56ee77f16010c (diff)
parenta93447b89a5b132221072e729d13a3f17391b8c2 (diff)
downloadpatches-2dd12924cf4a30a96262b6d392fcde58c9f10d4b.tar
patches-2dd12924cf4a30a96262b6d392fcde58c9f10d4b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/synergy.scm')
-rw-r--r--gnu/packages/synergy.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index 310a0f6194..8e863149c3 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -47,13 +47,15 @@
(modules '((guix build utils)))
(snippet
;; Remove ~14MB of unnecessary bundled source and binaries
- '(for-each delete-file-recursively
- `("ext/bonjour"
- "ext/LICENSE (OpenSSL)"
- ,@(find-files "ext" "openssl-.*\\.tar\\.gz")
- "ext/openssl-osx"
- "ext/openssl-win32"
- "ext/openssl-win64")))))
+ '(begin
+ (for-each delete-file-recursively
+ `("ext/bonjour"
+ "ext/LICENSE (OpenSSL)"
+ ,@(find-files "ext" "openssl-.*\\.tar\\.gz")
+ "ext/openssl-osx"
+ "ext/openssl-win32"
+ "ext/openssl-win64"))
+ #t))))
(build-system cmake-build-system)
(native-inputs `(("unzip" ,unzip)))
(inputs
@@ -78,9 +80,10 @@
(for-each
(lambda (f)
(system* unzip "-d" f (string-append f ".zip")))
- '("gmock-1.6.0" "gtest-1.6.0"))))))
+ '("gmock-1.6.0" "gtest-1.6.0"))))
+ #t))
(replace 'check
- ;; Don't run "integtests" as it requires network and X an display.
+ ;; Don't run "integtests" as it requires network and an X display.
(lambda _
(zero? (system* (string-append srcdir "/bin/unittests")))))
(replace 'install
@@ -103,11 +106,12 @@
(install-file (string-append srcdir "/doc/" e) ex))
'("synergy.conf.example"
"synergy.conf.example-advanced"
- "synergy.conf.example-basic"))))))))))
- (home-page "http://symless.com/")
+ "synergy.conf.example-basic"))))
+ #t))))))
+ (home-page "https://symless.com/synergy")
(synopsis "Mouse and keyboard sharing utility")
(description
- "Synergy brings your computers together in one cohesive experience; its
+ "Synergy brings your computers together in one cohesive experience; it's
software for sharing one mouse and keyboard between multiple computers on your
desk.")
(license gpl2)))