summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
commit5576cfabf3485e0cf794cc3de085a3578151ee64 (patch)
tree8ca4093d05fda6b0064d0fca429353327ec491f9 /gnu/packages/syndication.scm
parent12cb6c31df4b90d58658e88a256e36b6808e1064 (diff)
parente086d2f68b90a39bae07ae46572e5cc6b0fc4308 (diff)
downloadpatches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar
patches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 3e0cbe832a..1669f2c45c 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -32,7 +32,7 @@
(define-public newsboat
(package
(name "newsboat")
- (version "2.10.2")
+ (version "2.11")
(source
(origin
(method url-fetch)
@@ -40,7 +40,7 @@
"/newsboat-" version ".tar.xz"))
(sha256
(base32
- "1x4nxx1kvmrcm8jy73dvg56h4z15y3sach2vr13cw8rsbi7v99px"))))
+ "0yh1qdk15s9k4pffiw1155whfckpffq72dpyp9rck7yxgy5ya1hx"))))
(build-system gnu-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -49,7 +49,7 @@
("asciidoc" ,asciidoc)))
(inputs
`(("curl" ,curl)
- ("json-c" ,json-c-0.12) ; check whether json-c-0.12 can be removed
+ ("json-c" ,json-c)
("libxml2" ,libxml2)
("ncurses" ,ncurses)
("stfl" ,stfl)
@@ -64,6 +64,9 @@
#:make-flags
(list (string-append "prefix=" (assoc-ref %outputs "out")))
#:test-target "test"))
+ (native-search-paths
+ ;; Newsboat respects CURL_CA_BUNDLE.
+ (package-native-search-paths curl))
(home-page "https://newsboat.org/")
(synopsis "Text-mode RSS and Atom feed reader with podcast support")
(description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML